Connecting a Stereo Pair of RELs to a Single Amplifier

Follow

Comments

5 comments

  • Avatar
    BERNARD WLODARSKI

    re/ removing hum the presenter at 1m 50s speaks of connecting to "input" however the video at 1m 44s clearly shows connecting to "output" .

    0
    Comment actions Permalink
  • Avatar
    Juan Vasquez

    Keith, I found this in as a comment from REL in the above video in YouTube:

    "If your amplifier is Class D or Balanced/Differential, then the red and yellow wires will stay the same but the black wires should be left floating, or connected to a chassis ground screw. The Phase switch should be left in the position which gives you the loudest and deepest bass output. Typically with stereo pairs the phase switch will be in the same position for both subs."

    0
    Comment actions Permalink
  • Avatar
    Keith Swalin

    Andrew, did you ever get a response on this post? I too am considering two Rel t7x subs in stereo pair for a 4.2.2 system with an ATI class D amplifier. I can do LFE from my processor but the high level connection is a mystery.

    0
    Comment actions Permalink
  • Avatar
    Nils christensen

    Is there any problems connecting directly to the loudspeaker terminals ?

    0
    Comment actions Permalink
  • Avatar
    Andrew Wood

    What about connecting stereo with a class D?  I am thinking of getting a pair of HT/1003 with a Cyrus One (2021 purchased).

    -2
    Comment actions Permalink

Please sign in to leave a comment.